Job Processing Backlog
Incident Report for Scrutinizer
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 09:12 CET
Investigating
We are currently investigating this issue.
Posted Nov 13, 2019 - 08:57 CET
This incident affected: Workers.