External Network Route Leak causing Inspection Failures
Incident Report for Scrutinizer
Resolved
This incident has been resolved. We are continuing to monitor and re-open if further updates are needed.
Posted Jun 24, 2019 - 15:13 CEST
Update
The issue has been resolved upstream and we are seeing reduced error rates for inspections. We are continuing to monitor the situation and will update as necessary.

If you have a failed inspection related to node.js, a retry should now run through normally.
Posted Jun 24, 2019 - 14:46 CEST
Update
We are continuing to work on ways to mitigate this issue as best as possible on our end. We will keep you updated.
Posted Jun 24, 2019 - 14:40 CEST
Update
We have tracked the root cause down to an upstream issue with Cloudflare which we use https://www.cloudflarestatus.com/incidents/46z55mdhg0t5

For the moment, this issue is mitigated on our end. However, we are seeing errors for other domains (such as node.js) and believe this might be a wider Internet connectivity issue. As a result, inspections that install a node.js version are currently failing.

We are further investigating how to minimize the impact this has on your inspections and we will keep you updated here.
Posted Jun 24, 2019 - 13:22 CEST
Monitoring
We have temporarily mitigated and are continuing to investigate the root cause. Retried inspections should run through normally now.
Posted Jun 24, 2019 - 13:07 CEST
Identified
We have identified an issue in network connectivity which leads to communication failures between different components. We are continuing to investigate the root cause.
Posted Jun 24, 2019 - 13:00 CEST
Investigating
We are currently investigating this issue.
Posted Jun 24, 2019 - 12:41 CEST
This incident affected: Workers.