pythonhosted.org currently responding very slowly
Incident Report for Scrutinizer
Resolved
This incident has been resolved.
Posted Sep 04, 2018 - 16:20 CEST
Identified
The issue seems to be isolated to specific edge servers of pythonhosted.org. We are investigating further workarounds until fastly resolves this issue.
Posted Sep 04, 2018 - 15:58 CEST
Investigating
We are currently investigating this issue.
Posted Sep 04, 2018 - 15:35 CEST
This incident affected: Workers.