Increased Error Rates for Inspections
Incident Report for Scrutinizer
Resolved
This incident has been resolved.
Posted May 25, 2020 - 16:08 CEST
Investigating
We are currently investigating this issue.
Posted May 25, 2020 - 16:00 CEST
This incident affected: Workers.